WordPress homepage not updating with new posts and new theme

in CMS, Wordpress / 2 Comments

In this post I am going to explain my experience while change my theme. In recent days I have changed my blog theme and new logo. In the admin install new theme which is view-able now. But last weak the changes is not applied to my blog home page. For the internal pages and posts new theme is applied. In the home page new posts were not displaying. I have checked wordpress files in my hosting server. And clear browser caches. Then also new theme and new posts are not displaying.

Wordpress homepage not updating with new posts and new theme by Anil Labs

In earlier I have install hyper cache plugin to loading a page fast. That plug-in also deleted in admin. Then also new theme is not applied for home page.

Contact with some friends to check the issue. But they also didn’t find that issue. One of my blog author Vidhi was solved my issue, her earlier post in my blog is Website uptime monitoring using php script. She is good at php and wordpress.

In the starting of my blogging used W3 Total Cache plug-in. That plug-in needs to update the .htaccess file. I have update that file accordingly. And deleted that plugin in admin. But .htaccess file content which is added for cache plugin are not deleted by admin code.

The code in .htacees file

# BEGIN W3TC Page Cache core
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(.\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [L]
RewriteCond %{HTTP:Accept-Encoding} gzip
RewriteRule . - [E=W3TC_ENC:_gzip]
RewriteCond %{REQUEST_METHOD} !=POST
RewriteCond %{QUERY_STRING} =""
RewriteCond %{HTTP_HOST} =www.anil2u.info
RewriteCond %{REQUEST_URI} \/$ [OR]
RewriteCond %{REQUEST_URI} (sitemap(index)?\.xml(\.gz)?|[a-z0-9\]+-sitemap([0-9]+)?\.xml(\.gz)?) [NC]
RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp(app|cron|login|register|mail)\.php|\/feed\/|wp-.\.php|index\.php) [NC,OR]
RewriteCond %{REQUEST_URI} (wp\-comments\-popup\.php|wp\-links\-opml\.php|wp\-locations\.php) [NC]
RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|wordpress_\[a\-f0\-9\]\+|wordpress_logged_in) [NC]
RewriteCond %{HTTP_USER_AGENT} !(W3\ Total\ Cache/0\.9\.2\.4) [NC]
RewriteCond "%{DOCUMENT_ROOT}/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
RewriteRule . "/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
</IfModule>
# END W3TC Page Cache core

Removed those line of codes in .htaccess file then new theme and new posts are visible in blog page.

Discussion 2 Comments

  1. www.hcgaustralia.org

    I’m really enjoying the theme/design of your site. Do you ever run into any browser compatibility problems? A small number of my blog visitors have complained about my blog not operating correctly in Explorer but looks great in Safari. Do you have any recommendations to help fix this problem?

Leave a Reply

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>